Medium 5.3 CVSS 4.0 coingate Published on 2024-10-17

A vulnerability was found in CoinGate Plugin up to 1.2.7 on PrestaShop.

CVECVE-2018-25104 GHSANo GHSA advisory
View at the source View JSON Last modified at the source: 2026-06-17

Description

A vulnerability was found in CoinGate Plugin up to 1.2.7 on PrestaShop. It has been rated as problematic. Affected by this issue is the function postProcess of the file modules/coingate/controllers/front/callback.php of the component Payment Handler. The manipulation leads to business logic errors. The attack may be launched remotely. Upgrading to version 1.2.8 is able to address this issue. The patch is identified as 0a3097db0aec7c5d66686c142c6abaa1e126ca16. It is recommended to upgrade the affected component.

Original text by NVD (NIST), public domain.

CVSS metrics 4.0

Source: cna@vuldb.com · secondary
Medium 5.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/
Attack vectorNetwork
ComplexityLow
Attack requirementsNone
Privileges requiredLow
User interactionNone
Confidentiality (system)None
Integrity (system)Low
Availability (system)None
Confidentiality (others)None
Integrity (others)None
Availability (others)None

References

Found a vulnerability?

Write to the PrestaShop core security team:

security-core@prestashop.com

Do you use the coingate module?

PrestaShield checks it from the outside, without FTP access, and alerts you of every new advisory that affects you.
Check if my shop is affected