Medium 6.5 CVSS 3.1 Core Published on 2020-04-20

Improper Access Control

CVECVE-2020-5279 GHSAGHSA-74vp-ww64-w2gm
View at the source View JSON Last modified at the source: 2026-06-17

Description

Improper Access Control

Impact

There are improper access control since the version 1.5.0.0 for legacy controllers and API

Patches

The problem is fixed in 1.7.6.5

References

Improper Access Control - Generic (CWE-284)

Original text by NVD (NIST), public domain.

CVSS metrics 3.1

Source: security-advisories@github.com · secondary
Medium 6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Attack vectorNetwork
ComplexityLow
Privileges requiredLow
User interactionRequired
ScopeChanged
ConfidentialityLow
IntegrityNone
AvailabilityNone

References

Found a vulnerability?

Write to the PrestaShop core security team:

security-core@prestashop.com

Related advisories

Same component: PrestaShop core
All core advisories (94)
IDAdvisoryComponentSeverityAffected versionsPublishedFix
GHSA-whxq-pxj5-qq7v SQL injection through back-office list filters Core Medium 6.5 ≥ 9.0.0 < 9.1.5
≥ 8.0.0 < 8.2.8
2026-08-18 Yes
GHSA-2cr4-vw9p-pjvf Client IP address can be spoofed through the X-Forwarded-For header Core High 7.3 ≥ 9.0.0 < 9.1.5
≥ 8.0.0 < 8.2.8
2026-08-18 Yes

Is your shop on 1.7.x < 1.7.6.5?

PrestaShield checks it from the outside, without FTP access, and alerts you of every new advisory that affects you.
Check if my shop is affected